Jsnpp框架的安装以及升级
发布时间: 2021年5月7日 下午12:12 访问量: 300

Jsnpp框架是使用PHP语言开发的,所以对PHP版本有一定的要求,但是Jsnpp框架对PHP版本并不苛求,只需要大于等于5.6即可。

PHP版本要求

PHP >= 5.6

也就是说您的web环境安装了PHP5.6就可以正常使用Jsnpp框架,当然,如果您安装了PHP7,或者PHP8,都可以正常运行Jsnpp框架,官方建议PHP版本尽量使用高版本,例如PHP7.X或者PHP8.X。

安装方式

所谓的安装就是框架源代码的获取,Jsnpp框架必须通过Composer来安装,命令如下:

composer create-project yanzicms/jsnpp-app jsnpp-app

以上命令我们在《 如何获取Jsnpp源码》一篇里面已经介绍过了,详细内容这里不再赘述,如果您还不清楚的话,可以查看这篇文档。

升级方式

框架有新版本后需要升级,也要通过Composer方式来完成。命令如下:

composer update yanzicms/jsnpp

执行以上命令,需要先进入应用根目录,然后再执行命令升级。

Jsnpp框架跟其他主流框架一样,都使用了Composer方式来获取代码和升级版本,希望您能适应这种方式。

出错
/index/pagepassword.html
Jsnpp
自豪地采用 Jpwrt